Jump to content
Sign in to follow this  
The Krotek

IP.Board Login

Recommended Posts

Extends Joomla default user authentication to allow login with IP.Board credentials or email. After first successful login a new Joomla user will be created. All profile data will be taken from IP.Board.

 

Get more information and buy extension here.

Share this post


Link to post
Share on other sites

Hi Krotek, 

I'm running joomla 3.6.5 and IPB 4x (just upgraded to the latest version today)

Added in the database fields and set the jomsocial and IPB fields in the back end. I've then enabled the plugin and gone to log in with an IPB account. I just keep getting the login failed message.

I have the core login redirected to Jomsocial - I have tested by switching off and using the core joomla login but still encounter the same issue.

Checked the back end and the user isn't being created

The login i'm using for Joomla is working fine in IPB (its an Administrator account).

I have Admintools installed in case something is being blocked by the WAF.

 

Share this post


Link to post
Share on other sites

That's a non-standard message from some 3rd party extension. You need to find out, which extension returns this error and try to disable it. Maybe this is your problem.

Share this post


Link to post
Share on other sites

That's not the problem. That message is generated from the standard Jomsocial Redirect plugin. I've disabled that - reverted to the joomla login page and still unable to login with an IPB account

 

Warning

Username and password do not match or you do not have an account yet.

 

The website has a go live date of Sunday and I need to get the staff in form IPB to start populating content on Jomsocial, at the latest by tomorrow so fairly pressured to get this working ASAP.

I have messaged you an admin login to the backend in case you need it to help expedite this request

 

Many thanks 

N

Share this post


Link to post
Share on other sites

OK, that's better. This message means, that basic forum credentials check wasn't passed.

Which version of IPS Community Suite you have installed?

 

Share this post


Link to post
Share on other sites

Hi Support - did you have any luck? I have around 20 staff members waiting to login to start populating Jomsocial with content. Let me know if you require back end access.

Best

N

 

Share this post


Link to post
Share on other sites

I've just finished with the update. Spent most time implementing Joomla Update System, which is now required for all extensions.

As for your issue, I've checked, how IPS CS checks for credentials and nothing has changed it latest version. In plugin login/password are checked in absolutely the same way. The only difference was with legacy password characters escaping - plugin didn't have it. I've added it.

Maybe this was your issue, because you upgraded from IPB 3.0 and your passwords are probably still encrypted with previously used method. So download new version and try again. If it won't help, try to edit your forum profile and set a new password. It'll be encrypted with new method and should definitely work. If even after this you'll not be able to login, then problem is with some other authentication method or even deeper.

I've tested it a few times with new forum user. Tried to login with both username and email - worked perfectly, not a single issue. Should work for you as well.

NOTE: New version was renamed. You'll have to uninstall previous version before upgrade.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Sign in to follow this  

×