Jump to content
The Krotek Support Forum
  • Sign Up
simplecms

Ban system setup - but no blocking is happening

Recommended Posts

I've setup the ban system fully and added three "like" bans on email field. Yet if I test by going through checkout with one of those 3 email domains that are banned the transaction still goes through as normal. Here's the screenshots of my setup:

https://www.awesomescreenshot.com/image/3862219/d0f38a7f98a994fa7fc9722782a41839

https://www.awesomescreenshot.com/image/3862220/288b19a110c1f18452ea60130542416b

Share this post


Link to post
Share on other sites

If you're using it with custom checkout extension, it might not work out-of-the-box. You need to customize it and make compatible with your custom checkout. But first try it with default checkout, see, if it works.

Share this post


Link to post
Share on other sites

We are not using any custom checkout extension. We have tested with the default checkout and no ban of our terms happens. Please let us know what to do.

Share this post


Link to post
Share on other sites

If even on default checkout it doesn't work, then only 2 reasons are possible:

- Wrong/incomplete extension setup.

- Rules are not properly set or data don't match.

See the documentation, make sure you installed everything properly, and then check the rules you want to apply.

Share this post


Link to post
Share on other sites

You can see our setup in the screenshots I linked to. As far as I can see all is setup correctly per your documentation. Can you please look at the screenshots to verify?

Share this post


Link to post
Share on other sites

Just added the same rule on our demo site and tested it with default checkout - worked perfectly. You can test it yourself here - enter any email with yandex.com domain.

I'm sorry, but I can only repeat, that problem is with your setup somewhere. Check your modification log, make sure Ban System modification was properly processed. Check the error log for any related errors.

There's also a chance, that you have a compatibility issue with another extension.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...