Jump to content
The Krotek Support Forum
  • Sign Up
The Shadow

VK and OK paramter problems.

Recommended Posts

Having started wit Twitter, things there work reat.

However to get vKontakte and Odnoklassniki working eems to b a bit more challenging.

vKontakte: I have followed the setup istrucions twice, but still get this error:

User fetching error: User authorization failed: invalid access_token (4).

I am attaching  screenshot of the VK settings, please see what should be changed

Odnoklassniki: As they do not wrk on Saturday, the error may be in the support needing to add the permssions as mentioned in the setup instructions.

However I am unsure that not something else maz be wrong. The current error is:

Token retrieval failed: Invalid request parameters

Also screenshot of settings attached.

ok1.jpgok1.pngok2.jpg

ok3.jpgvkontakte.jpg

Share this post


Link to post
Share on other sites

User fetching error: User authorization failed: invalid access_token (4).

The error says for itself: invalid access token. You entered wrong data for Access Token field.

Token retrieval failed: Invalid request parameters

Same here: some parameters are entered improperly.

Read the documentation and check everything multiple times. Even a single wrong character or a space can ruin everything.

Also read ALL error messages, they usually tell you, what is wrong. Most errors are returned by social networks themselves, so you can simply search by error message (text after ":") in Google for suitable solution.

Share this post


Link to post
Share on other sites

While I can make errors, copyng and pasting keys and ensuring no spacs are eft is not something I usually do wrong.

Twitter also refused authentication, where as on th test site it worked without an issue.

When searching the error on Google I came to something that seems a recurring issue: time.

According to the article the OAuth method includes a time. The server of the website is located in France. The test site had no time correction however the main site is on Moscow time.

Both sites are on similar though separate virtual machines running on the same dedicated server. I upgraded ntp in order to see if that solves the issue.

The test site and main do have different twitter accounts, but the app settings are equal and I have ensured once again no spaces or other things are present on either side of anz of the keys.

Any suggetions ?

Share this post


Link to post
Share on other sites

Update: a server restart did ause some progress. vKontakte is now posting, after the firt issue was solved there was an error in group permissions which was solvd by recreating the app.

Odnoklassniki I will wait for the support to handle the permissions mail and see if after that things will work if not go over all parameters again.

Twitter posted once and then went back to global error 32. Bck to the drawing board and re-check all.

Share this post


Link to post
Share on other sites

I'm sorry, but I didn't understand anything you said - too many errors and descriptions are extremely confusing.

Anyway, most errors in Social Crossposting are from social networks and they usually tell you, what's wrong. For most errors at least some results are returned in Google, because a lot of people are having issues with app setup.

Don't forget to check crossposting report - it tells you everything.

Share this post


Link to post
Share on other sites

Sorry for mistakes in spelling. Am I corrct you use Google translate and can not read English? If os I will ask a friend to translate to Russian. I thank you for fast answers and will not give up until all works perfct.

Share this post


Link to post
Share on other sites

Setup of social network applications can some times be quite hard, indeed. Especially, when you do it for the first time. But since a lot of people using these apps, there's always a solution out there. I don't have a solution for every issue myself and have to search in Google pretty often myself. So it's pretty much normal.

Share this post


Link to post
Share on other sites

Nearly there. Twitterm vKontate work. Odnoklassniki waiing for support to get in to office nad give permisions.

Facebook does post but without image. We try a animated gif of 3Mb. Is this permission problem or other problem?

Share this post


Link to post
Share on other sites

Do not see result of the meta tags. However the cron does not ive output but breaks down. Good thing is ok.ru is working perfect, which is most imporant. When there is a new question I will ask you. Thank you for your help, I appreciate you are replying at almost all hours.

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×